How do i redirect on my Server 2012 R2 incoming domain requests?

I have two virtual machines on my server which use port 80.
How do i redirect
sub1.home.home to machine 1
and
sub2.home.home to machine 2

I think my router is not capatable for that, so port 80 needs to be handled somehow on the server.

Thanks for hints and help.

Related:

Nginx server_name issue on HTTPS for multiple applications(vhosts)

I have two application on server which where were working perfectly until I planned to switch them to HTTPS.

Nginx config for app 1:

server_name abc.com my.abc.com static.abc.com

Confing for app 2:

server_name _;

Before enabling SSL both apps were working e.g.

App1 http://static.abc.com/some-assets.png

App2 http://static.def.com/some-assets.png

After enabling SSL

App1 https://static.abc.com/some-assets.png

App2 https://static.def.com/some-assets.png

If I try to access App2 https://static.def.com/some-assets.png now is also pointing to App 1 somehow.

I tried to dig out and found if I replace server_name _; with server_name static.def.com; in App 2 Nginx config its start working.

My question is it required for Nginx to explicitly define the domains if you want to serve them over HTTPS? Or is it something with SSL handshake is failing etc. and its ends up like this?

Related:

Log shipping between SQL 2012 and 2016 instances

My question is about SQL Server log shipping from instance having SQL 2012 and SQL 2016.

Is it possible to implement? The error I am getting is, SQL server doesnt allow database/log to be restored in standby mode, which is required shipping the logs.

Is there any way to implement it?

Thanks

Related:

Error: Your request can’t be completed right now. Please try again later. exchange server 2013

previously i steuped a exchange server 2013 on a 2013 R2 few hours it worked well but now it shows
Error: Your request can’t be completed right now. Please try again later.
when accessing mail through https://localhost/owa all the email headers are visible but the email body says above i checked the internet so many forums but no help

enter image description here

in IIS EXchange back end site -> owa -> anonymous authentication enabled

Related:

TFS 2015 Unable to deploy to to specific server, but Visual Studio can from the Build Agent server

I’m at a bit of a loss here, having checked all the usual suspects.

One of the most baffling things is that I can deploy via Visual Studio on the Build Agent server, using the same url to the same server, same code (Literally copied the Visual Studio solution from the build agent s folder of the latest build)

When building via TFS 2015 however, I’m seeing the following:

C:\Program Files (x86)\MSBuild\Microsoft\VisualStudio\v14.0\Web\Microsoft.Web.Publishing.targets(4276,5):
Error : Web deployment task failed. (Could not complete the request to remote agent URL ‘https://siteurl:8172/msdeploy.axd?site=sitename‘.)

This error indicates that you cannot connect to the server. Make sure the service URL is correct, firewall and network settings on this computer and on the server computer are configured properly, and the appropriate services have been started on the server.

Error details:

Could not complete the request to remote agent URL ‘https://siteurl:8172/msdeploy.axd?site=sitename‘.

The underlying connection was closed: An unexpected error occurred on a send.

Unable to read data from the transport connection: An existing
connection was forcibly closed by the remote host.

An existing connection was forcibly closed by the remote host

In addition, the WMsvc log on the target IIS server does not show a request hitting the server when TFS does the build, however when Visual Studio does the build, it does reach the server.

The MSBuild arguments passed in TFS (line breaks added for readability):

/p:GenerateBuildInfoConfigFile=false 
/p:DeployOnBuild=true;
DeployTarget=MSDeployPublish;
MSDeployPublishMethod=WMSvc;
EnableMSDeployBackup=False;
DeployIisAppPath=sitename;
MsDeployServiceUrl=https://siteurl:8172/msdeploy.axd;
AllowUntrustedCertificate=True;
username=$(Web Deploy Username);
password=$(Web Deploy Password);
SkipExtraFilesOnServer=True

The build definition was copied from another working build with the only changes being the url and the configuration.

It seems like it’s a network issue, but I don’t know why it would work from the same server via Visual Studio, but not via TFS if the source (TFS Build Agent server) and the destination (IIS Web server) are the same, the port is the same, both using https, Web Deploy etc.

Any ideas on how to further debug?

Additional Info:

Target Server:
Windows Server 2012R2 (VM on Azure)

Related:

websocketserver behind nginx and apache

How is it possible to establish a websocket connection through nginx and apache, where both act as reverse proxies.

The system is setup with apache on the main host and a tornado webapplication in a container.

My apache config d is as follows:

<LocationMatch /container_path/(?<app>(.+))/ws >
        ProxyPass                       "ws://container_ip/app_name/%{env:MATCH_APP}/ws"
        ProxyPassReverseCookiePath      "/"  "/container_path/"

</LocationMatch>

My nginx config is something like the followed:

upstream backend {
        server 127.0.0.1:8888;
}

server {
    listen 80;


    location ~ /ws$ {

        proxy_pass http://backend;

        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
    }
}

With this settings, I get a 400 Bad Request status from the WebSocketHandler of tornado.

Thx in advance for every hint

Related:

A secure way to access database from a Cordova app

I have a question about my Cordova app server architecture, and I’m sorry if this is a very basic question for you.

I’m developing a Cordova app and I’ve got the UI ready but I need data to my app from a database. For example I want my cordova app to include user authentication when the user opens the app which means, I have to access my database in some way to check the user input. I would also like to get data from the database and show in the app such as the members information, ranking and so on. How do I do this in a easy and proper way? Am I right when I say that there is not a good thing to access a database directly from the javascript in the cordova app, for security reasons?

Is the solution through a architecture that looks like this?

Cordova app(In Google play) –> Application Server –> Database

Thanks!

Related:

Windows Update – translate Update GUID until Update "Microsoft KB" Number?

Am troubleshooting a complete windows update failure – on a brand new install, standalone Windows 2012 Server Essentials. Zero config, no existing infrastructure, “straight out of the box” setup.

Windows Update never gets going at all – but strangly have installed it in the past from this exact install media on this exact server.
Yet, now it fails. The only rational reason I can imagine is a new update has recently been released that breaks windows update for this OS version on a fresh install.

The last entries from the WindowsUpdate.log are:

2017-01-18  15:11:14:840     412    1424    Agent   WARNING: Failed to evaluate Installable rule, updateId = {E66A6795-3E20-43ED-9C66-FE134EEEECBC}.200, hr = 80070057
2017-01-18  15:11:19:324     412    1424    Agent   Bundled update {FBEC0F80-9F87-4B42-BA14-2BBE7148322A}.203 is missing extended metadata
2017-01-18  15:11:19:324     412    1424    Agent   Bundle contains children which has no localextended metadata and thus is invalid.
2017-01-18  15:11:19:324     412    1424    Agent   Update {B27CF4B3-0B7D-475D-9129-883E6DED6182}.203 is not a valid bundle. Not returning it.

Question: Does the above mean that there is a specific invalid/corrupted Update that the server is trying to fetch?

If so, is it possible to translate the hex/guid update ID codes ({B27CF4B3…}) into Microsoft KB Update ID? So one may research the specific update that is causing the problem?

Related:

Only send SCOM alerts for a spacific set of copmuters to OMS

How do we configure SCOM 2012 R2 to only send a certain set of computers to OMS. We are only wanting to send our production server’s alerts up to OMS. We have servers selected in the OMS section, but it doesn’t seem to do anything; SCOM still sends all alerts to OMS. We would prefer to use a dynamic group, as our servers names are prefixed for prod servers.

Related:

  • No Related Posts

External IP configuration – connection being refused

I created a VM-instance, say myVM on GCE.
I assigned an external IP address during this. I then changed this
IP address from ephemeral to static. When I look up at
External IP Addresses page (https://console.cloud.google.com/networking/addresses/list),
I see that IP listed as static type and “In use by” myVM.

when I look up myVM on the console,
i see that myVM has both its internal and external IP-s set– external IP to that static one.

And this is what Google Cloud Shell says:

$ gcloud compute addresses list
NAME      REGION       ADDRESS           STATUS
myip-tmp  us-central1  <my-ext-IP-here>  IN_USE

My firewall rules are as follows:

$ gcloud compute firewall-rules list
NAME                    NETWORK  SRC_RANGES    RULES                         SRC_TAGS  TARGET_TAGS
default-allow-http      default  0.0.0.0/0     tcp:80                                  http-server
default-allow-https     default  0.0.0.0/0     tcp:443                                 https-server
default-allow-icmp      default  0.0.0.0/0     icmp
default-allow-internal  default  10.128.0.0/9  tcp:0-65535,udp:0-65535,icmp
default-allow-rdp       default  0.0.0.0/0     tcp:3389
default-allow-ssh       default  0.0.0.0/0     tcp:22
default-allow-tomcat    default  0.0.0.0/0     tcp:8080

There doesn’t seem to be anything wrong with my routing configuration (https://cloudplatform.googleblog.com/2015/07/Connection-Refused.html):

$ gcloud compute routes list
NAME                            NETWORK  DEST_RANGE     NEXT_HOP                  PRIORITY
default-route-097757cca4bcea23  default  10.128.0.0/20                            1000
default-route-188df012191065e7  default  10.132.0.0/20                            1000
default-route-1f4b4268226c612d  default  10.138.0.0/20                            1000
default-route-2741ac2c32a51d91  default  10.146.0.0/20                            1000
default-route-483e39a1a5e667a4  default  0.0.0.0/0      default-internet-gateway  1000
default-route-60eb77946bc9d9c4  default  10.140.0.0/20                            1000
default-route-d40f47fb8b8a867f  default  10.142.0.0/20                            1000

when i

$ curl localhost
0.1/
computeMetadata/

on GCloud Shell, i see the response. however, my external IP is still not active. when i make a call to it from wherever, i get an error:

$ curl <my-ext-IP-here>
curl: (7) Failed to connect to <my-ext-IP-here> port 80: Connection refused

What am i missing??

i’m running these on a Debian 8 image, in case it matters.

My first time with GCE or any other cloud. Excuse the naive Q if so.

//—————————–

UPDATE:

netstate gave me this:

$ sudo netstat -tnlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 127.0.0.1:8998          0.0.0.0:*               LISTEN      214/python      
tcp        0      0 127.0.0.1:57418         0.0.0.0:*               LISTEN      210/0           
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      216/python      
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      27/sshd         
tcp        0      0 0.0.0.0:13080           0.0.0.0:*               LISTEN      199/nginx       
tcp        0      0 0.0.0.0:13081           0.0.0.0:*               LISTEN      199/nginx       
tcp        0      0 0.0.0.0:13082           0.0.0.0:*               LISTEN      199/nginx       
tcp        0      0 0.0.0.0:13083           0.0.0.0:*               LISTEN      199/nginx       
tcp        0      0 0.0.0.0:13084           0.0.0.0:*               LISTEN      199/nginx       
tcp        0      0 0.0.0.0:13085           0.0.0.0:*               LISTEN      199/nginx       
tcp6       0      0 :::22                   :::*                    LISTEN      27/sshd 

I got the following from tcpdump:

$ sudo tcpdump -n icmp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 262144 bytes
^C
0 packets captured
0 packets received by filter
0 packets dropped by kernel

$ sudo tcpdump -n host <my-ext-IP-here>
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 262144 bytes
^C
0 packets captured
0 packets received by filter
0 packets dropped by kernel

Related: