7018775: Missing Filr context menu if the storage location was changed with a case mismatch

If a user changes the default storage location for the Filr Desktop client from the default (C:UsersJohnFilr) to a different drive such as E: but types the target drive letter in lower-case, the folder gets moved successfully but the new location no longer show any of the Filr context menus.

For example: User wants to move Filr Storage location from C:UsersJohnFilr to E:UsersJohnFilr. However, instead of using the Browse button next to storage location, user manually types the new location as e:UsersJohnFilr and saves the changes. The folder gets moved and user can browse files in the new location, however if the user right-clicks on any folder or file, the Filr context menu is missing.

Related:

7018772: Filr Windows Desktop client deletes files due to file name case mismatch

In some Windows 7 and Windows 10 systems, the initial scan of the flesystem (brute-force scan) to detect any file changes triggers a series of delete requests on files that have been modified but are reported in all uppercase letters.

The following snippet from user’s Deskop client log the system returning folder names in All Uppercase:

2017-02-17 07:17:27,813 [filesync-monitor] [INFO] Begin brute force scan of file system to determine if anything has changed (aca.filesync2.watcher.local)

…..

…..

2017-02-17 07:18:18,987 [filesync-monitor] [INFO] Moved folder: 2017-BudgetReturn Process (2489) -> 2017-BudgetRETURN PROCESS (2489). (aca.filesync2.watcher.local)

2017-02-17 07:18:19,019 [filesync-monitor] [INFO] Moved folder: Finance documents2011Bayer (7775) -> Finance documents2011BAYER (7775). (aca.filesync2.watcher.local)

…..

…..

2017-02-17 07:21:48,131 [filesync-monitor] [INFO] Completed brute force scan of file system to determine if anything has changed (aca.filesync2.watcher.local)

Related:

7018774: Filr folders appear empty if VMWare Mirage is installed

This document (7018774) is provided subject to the disclaimer at the end of this document.

Environment

Micro Focus Filr 3.1

Micro Focus Filr Desktop client 3.1

Novell Filr 2.0

Novell Filr Desktop client 2.0

Situation

When Filr Desktop client is installed on a Windows system which has VMWare Mirage installed, the Filr folder appears empty and fails to show files that user has access to.

Resolution

A fix for this issue is available in the Filr 2.0 Hot Patch 4 and Filr 3.1.1 update, available via the Novell Patch Finder.

Cause

The altitude for FilrDriver and VMWare Mirage is the same value (= 370030) which leads to this problem.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented “AS IS” WITHOUT WARRANTY OF ANY KIND.

Related:

7018773: Filr Driver prevents Windows Backups

This document (7018773) is provided subject to the disclaimer at the end of this document.

Environment

Micro Focus Filr 3.1

Micro Focus Filr Desktop client 3.1

Novell Filr 2.0

Novell Filr Desktop client 2.0

Situation

On some Windows 10 systems, the Windows Backup utility fails to create backups on the attached USB / Backup device. If the backup is attempted with the Filr driver stopped, the backup succeeds without problem.

Resolution

A fix for this issue is available in the Filr 2.0 Hot Patch 4 and Filr 3.1.1, available via the Novell Patch Finder.

Cause

Starting with Windows 10, Microsoft uses the USN Journal feature in the backup. When a backup is attempted, Windows attempts to read the USN journal information for each of the folders present in the user profile. Since Filr does not support the journal information, the backup is failing. This USN journal was present in earlier versions of Windows but it was not used during backups.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented “AS IS” WITHOUT WARRANTY OF ANY KIND.

Related: