Exchange Server 2013 Toolbox MMC Error ConsoleInitialize.ps1 not recognised

after installing and configuring Exchange 2013 during a migration from 2010 (with both versions still running), I am now receiving a ConsoleInitialize.ps1 System.Management.Automation.RemoteException exception when trying to run the Management Toolbox (I am really after the Queue Viewer).

This is the same when trying to connect locally on the server and remotely on a client computer with Management Tools installed – I can use EMC without any errors locally or remotely.

I have tried various fixes found around the net, including:

  • Changing the Identity of the Classic and DefaultAppPools in IIS and resetting – from LocalSystem to ApplicationPoolIdentity
  • Adding the roles to Exchange Organisation Management in AD
  • Disabling SSL on the Powershell virtual Directory and setting auth to anonymous

I have not tried recreating the Powershell virtual directory as mentioned on a few sites, as I have not been able to test that in the lab, and I am not sure how it affects the powershell session that I am doing it from.

The only thing that I can think that could be an issue is that Ex2010 is still up and running, could it be that Management Tools is looking at the old server, instead of the new?

Can anyone point me in the right direction with this one?

I can post more info if required.

Thank you.


Leave a Reply