CVE-2008-1447 – Vulnerability in Access Gateway Standard and Advanced Edition Appliance firmware could result in DNS Cache Poisoning

Description of Problem

A vulnerability has been identified in the Access Gateway Standard and Advanced Edition appliance firmware that could affect the functionality of Domain Name System (DNS) forwarding in the Access Gateway appliance. The background and details for this vulnerability are similar to those described in U.S. Computer Emergency Readiness Team (CERT) Vulnerability Note VU#800113, which can be seen at the following location:

http://www.kb.cert.org/vuls/id/800113

Citrix has verified that the firmware of the appliances for both Access Gateway Standard Edition and Advanced Edition product lines are vulnerable to this issue in all configurations.

The CERT reported vulnerability has been assigned the following CVE number:

    • CVE-2008-1447

This vulnerability is present in versions of all versions the Access Gateway Standard and Advanced Edition appliance firmware up to and including v 4.5.7 Rev A.

What Customers Should Do

New firmware has been released to address this issue. Citrix strongly recommends that all customers with products affected by this issue install the new firmware, available from the following locations:

Access Gateway Standard and Advanced appliances:

Firmware version 4.5.8

http://support.citrix.com/article/CTX118293

Firmware version 4.5.7 Rev B

http://support.citrix.com/article/CTX116762

Customers using Access Gateway Standard and Advanced Edition appliances with firmware versions earlier than 4.5 are advised to contact their customer support representative for assistance.

Citrix recommends that customers using the Windows Server component of Access Gateway Advanced Edition apply the appropriate Microsoft patches for this issue to their underlying operating system.

Acknowledgements

Citrix would like to thank Dan Kaminsky of IOActive and Paul Vixie of Internet Systems Consortium, Inc. (ISC) for working with us to protect Citrix customers.

What Citrix Is Doing

Citrix is notifying customers and channel partners about this potential security issue. This article is also available from the Citrix Knowledge Center at http://support.citrix.com/.

Obtaining Support for this Issue

If you require technical assistance with this issue, please contact Citrix Technical Support. Information for contacting Citrix Technical Support is available at http://www.citrix.com/English/ss/supportContacts.asp.

Reporting Security Vulnerabilities to Citrix

Citrix welcomes input regarding the security of its products and considers any and all potential vulnerabilities seriously. If you would like to report a security issue to Citrix, please compose an e-mail to secure@citrix.com containing the exact version of the product in which the vulnerability was found and the steps needed to reproduce the vulnerability.

Related:

  • No Related Posts

Leave a Reply