CVE-2009-1389 – Vulnerability in XenServer 5.0 and 5.5 Could Result in Arbitrary Code Execution

Description of Problem

The RealTek 8169 Linux network adaptor driver used in XenServer fails to correctly handle long packets. This could result in denial of service (hard crash of the host) or remote execution of code.

This vulnerability has been assigned the following CVE number:

    • CVE-2009-1389

This vulnerability affects the following products:

    • XenServer 5.0 Update 3, and earlier

    • XenServer 5.5

Mitigating Factors

The vulnerability is specific to the Realtek 8169 driver. No other drivers are affected.

What Customers Should Do

A hotfix has been released to address this issue. Citrix recommends that affected customers install this hotfix, which can be downloaded from the following locations:

Citrix XenServer 5.0:

http://support.citrix.com/article/CTX123192

Citrix XenServer 5.5:

http://support.citrix.com/article/CTX123673

What Citrix Is Doing

Citrix is notifying customers and channel partners about this potential security issue. This article is also available from the Citrix Knowledge Center at http://support.citrix.com/article/CTX123453.

Obtaining Support on this Issue

If you require technical assistance with this issue, contact Citrix Technical Support. Information for contacting Citrix Technical Support is available at http://www.citrix.com/English/ss/supportContacts.asp.

Reporting Security Vulnerabilities to Citrix

Citrix welcomes input regarding the security of its products and considers any and all potential vulnerabilities seriously. If you would like to report a security issue to Citrix, please compose an e-mail to secure@citrix.com containing the exact version of the product in which the vulnerability was found and the steps needed to reproduce the vulnerability.

Related:

  • No Related Posts

Leave a Reply