Remote Code Execution Vulnerability in Citrix Workspace app and Receiver for Windows

A new version of Citrix Workspace app and Receiver for Windows has been released. Citrix strongly recommends that customers upgrade Citrix Workspace app to version 1904 or later and Receiver for Windows to LTSR 4.9 CU6 version 4.9.6001.

The new Citrix Workspace app version is available from the following Citrix website location:

https://www.citrix.com/downloads/workspace-app/

The new LTSR version is available from the following Citrix website location:

https://www.citrix.com/downloads/citrix-receiver/windows-ltsr/receiver-for-windows-ltsr-latest.html

Single Sign-on (SSO) could stop working, after applying the security update, for browsers other than Internet Explorer unless explicitly configured. Use the following documentation to ensure proper configuration post fix installation:

https://support.citrix.com/article/CTX133982

Related:

  • No Related Posts

Leave a Reply