7018998: iPrint Driver store page shows missing plugin error from Mac browser.

This document (7018998) is provided subject to the disclaimer at the end of this document.

Environment

Micro Focus iPrint Appliance 3.0

Situation

When attempting to manage the Driver Store within iManager from Safari on a Mac workstation, the following message is returned:

This page has content that requires an internet plug-in.

This page contains content of “application/novell-iprint-plugin” type. You do not have the plug-in required to view this content.

Resolution

  1. Install Patch 1 for the iPrint Appliance 3.0.
  • iPrint Appliance patches are installed through the Online Update feature.
    • https://<ip or dns>:9443
    • Click the “Online Update” button/link.
    • Register the Appliance
      • The registration activation number can be obtained through the Subscriber Portal, click the “Professional Resource Suite Electronic” link to the right, then click the “Request Software Registration Codes”.
    • Update the Appliance
      • Highlight the Patch 1 update, and click “Update Now”
  • This update will add the updated iPrint Plugin to resolve this, but will not install the plugin.
  • Install the updated plugin.
    • Paste the following string of commands into a terminal session to the Appliance while logged in as root:
    • /usr/bin/java -Xms64m -Xmx96m -Dcom.ibm.tools.attach.enable=no -cp /var/opt/novell/tomcat6/lib/tomcat6-servlet-2.5-api-6.0.45.jar:/var/opt/novell/iManager/nps/WEB-INF/classes:/var/opt/novell/iManager/nps/WEB-INF/lib/eMFrame.jar:/var/opt/novell/iManager/nps/WEB-INF/lib/AdminNamespace.jar:/var/opt/novell/iManager/nps/WEB-INF/lib/rbsCore.jar:/var/opt/novell/iManager/nps/WEB-INF/lib/iManagerModuleInstall.jar com.novell.application.iManager.install.InstallNPMsOnLinux_OES211 install /var/opt/novell/iManager/nps/packages/iPrint_Linux_iMan27.npm;rm -r /var/opt/novell/tomcat6/work;rcnovell-tomcat6 restart

    Cause

    NPAPI plugin was blocked by browsers in MAC, as the plug-in is specific to Windows. The fix has been shipped with iPrint Appliance 3.0 Patch 1, however the patch does not auto install the iPrint iManager plugin. Following step 2 within the Resolution section of this document is required to install the plugin.

    Disclaimer

    This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented “AS IS” WITHOUT WARRANTY OF ANY KIND.

    Related:

    Leave a Reply