7021011: Package Manager – No Package updates are available from the Update Channel when trying to upgrade to a new major or minor release

This document (7021011) is provided subject to the disclaimer at the end of this document.

Environment

NetIQ Privileged Account Manager

Situation

A new version of PAM has been recently released, unable to upgrade / update to the latest version

In the Package Manager Console, selecting Check for Updates reports the following browser dialog error:

No Package updates are available

The following is displayed in the unifid.log:

Warning, Failed to receive package list from https://nu.novell.com/PUM/packages/Engine/package.idx 404(Not Found)

Info, pkgman listAvailable client:localhost user:admin@<pamPkgmanHost>(<IP-Address>) rc:0 status:0

Resolution

Selecting “Check for Updates” in the Package Manager Console will only search for patch or hotfix releases for the current major.minor release.

To upgrade to a new major or minor release, please select “Add Packages”

Cause

“Check for Updates” was selected, yet there are no available patch or hotfix releases to update.

Additional Information

Here are a couple examples for further clarification:

  • If needing to upgrade from PAM 3.1 to 3.2, then this is a minor release upgrade, which means “Add Packages” should be selected.
  • If needing to update from PAM 3.1 to 3.1.0.3, then this is a hotfix release update, which means “Check for Updates” should be selected.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented “AS IS” WITHOUT WARRANTY OF ANY KIND.

Related:

Leave a Reply