7023237: Update from ZENworks 2017 could fail if OS was upgraded or migrated from SLES 11 to SLES 12

This document (7023237) is provided subject to the disclaimer at the end of this document.

Environment

ZENworks Configuration Management 2017 System Update

ZENworks Configuration Management 2017 Update 1 System Update

ZENworks Configuration Management 2017 Update 2 System Update

ZENworks Configuration Management 2017 Update 3 System Update
ZENworks Configuration Management 2017 Virtual Appliance
SUSE Linux Enterprise Server 12

Situation

  • ZENworks Primary Server running SUSE Linux Enterprise Server (SLES)
  • Primary Server operating system upgraded from SLES 11 to SLES 12 (standalone)
  • Primary Server appliance migrated from ZENworks 11.4 (virtual appliance)
  • Primary Server updated from ZENworks 2017 to 17.1, 17.2, or 17.3
  • ZENworks agent service (novell-zenworks-xplatzmd) may not be started on the Primary Server
  • Primary Server operating system showed as SLES 11 in ZENworks Control Center (ZCC) at the time of system update deployment
The following could be seen in the system-update.log:
ERROR:
[ZENUpdater] [] [root] [SystemUpdate] [RPM_INSTALL_ERROR] [ERROR] [(/bin/rpm -U -vv –replacefiles /var/opt/novell/zenworks/content-repo/system-update/5017020a00fc50000000002018013116/rpm/sles-11-x86_64/novell-zenworks-ruby-1.8.7.p72-22.1.x86_64.rpm),1]

[ZENUpdater] [] [root] [SystemUpdate] [RPM_INSTALL_ERROR] [ERROR] [(/bin/rpm -U -vv –replacefiles /var/opt/novell/zenworks/content-repo/system-update/5017020a00fc50000000002018013116/rpm/sles-11-x86_64/novell-zenworks-facter-1.5.7-3.1.x86_64.rpm),1]

[ZENUpdater] [] [root] [SystemUpdate] [RPM_INSTALL_ERROR] [ERROR] [(/bin/rpm -U -vv –replacefiles /var/opt/novell/zenworks/content-repo/system-update/5017020a00fc50000000002018013116/rpm/sles-11-x86_64/novell-zenworks-libsolv-helpers-17.2.0_0.6.28-4.1.x86_64.rpm),1]

[ZENUpdater] [] [root] [SystemUpdate] [RPM_INSTALL_ERROR] [ERROR] [(/bin/rpm -U -vv –replacefiles /var/opt/novell/zenworks/content-repo/system-update/5017020a00fc50000000002018013116/rpm/sles-11-x86_64/novell-zenworks-puppet-2.7.19-5.1.x86_64.rpm),1]

[ZENUpdater] [] [root] [SystemUpdate] [RPM_INSTALL_ERROR] [ERROR] [(/bin/rpm -U -vv –replacefiles /var/opt/novell/zenworks/content-repo/system-update/5017020a00fc50000000002018013116/rpm/sles-11-x86_64/novell-zenworks-xplat-x11vnc-0.9.9-3.1.x86_64.rpm),1]

[ZENUpdater] [] [root] [SystemUpdate] [RPM_INSTALL_ERROR] [ERROR] [(/bin/rpm -U -vv –replacefiles /var/opt/novell/zenworks/content-repo/system-update/5017020a00fc50000000002018013116/rpm/novell-zenworks-xplat-puppethandler-17.2.0-860.noarch.rpm),1]
Dependency errors could be seen in the individual rpm install logs. For example, the following could be seen in novell-zenworks-ruby-1.8.7.p72-22.1.x86_64.rpm.log:

error: Failed dependencies:

libgdbm.so.3()(64bit) is needed by novell-zenworks-ruby-1.8.7.p72-22.1.x86_64

libgdbm_compat.so.3()(64bit) is needed by novell-zenworks-ruby-1.8.7.p72-22.1.x86_64

libreadline.so.5()(64bit) is needed by novell-zenworks-ruby-1.8.7.p72-22.1.x86_64

Resolution

  1. Delete the problem system update from ZCC
  2. Start the ZENworks agent service on the Primary Server: systemctl start novell-zenworks-xplatzmd.service
  3. Refresh the ZENworks agent on the Primary Server: zac ref bypasscache
  4. Verify that the Primary Server operating system shows as SLES 12 in ZCC

    NOTE: If the operating system still shows as SLES 11, please contact Micro Focus Customer Support.
  5. Download the system update again
  6. Deploy the system update to the Primary Server again

Cause

The Primary Server operating system was showing as SLES 11 when the system update was downloaded and deployed. Because of this, the update commands were built for SLES 11 instead of SLES 12. These SLES 11 packages throw dependency errors when an install is attempted on SLES 12.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented “AS IS” WITHOUT WARRANTY OF ANY KIND.

Related:

Leave a Reply