When trying to remove a delivery group from an application in Studio after renaming/editing application name within application properties in the same step, getting the error “object does not exist” .

When trying to remove a delivery group from an application in Studio after renaming/editing application name within application properties in the same step, getting the error “object does not exist” .

The above error will come when trying to remove a delivery group, adding the delivery group will not an issue(the removal fails, but the addition succeeds.)

Opening the application properties again to try the removal again then succeeds.

Note: The issue will only be seen when we try to change application name and remove the delivery group in the same step.



Error Id: XDDS:1F0D5809

Exception:

Citrix.Console.Models.Exceptions.ObjectNotFoundException Object does not exist.

at Citrix.Console.PowerShellInteraction.CmdletExecutionMethods.CreateException[T](ICommonLog logger, ExecutionResults`1 results, ICmdletExecutionHost host)

at Citrix.Console.PowerShellInteraction.CmdletExecutionMethods.Execute[T](ISdkCmdlet`1 sdkCmd, ICmdletExecutionHost host, Boolean allowFailover)

at Citrix.Console.PowerShellSdk.ApplicationService.Scripts.GetApplicationSearchScript.PopulateCommandWithParametersAndExecute(GetBrokerApplicationCmd getApplicationsCommand)

at Citrix.Console.PowerShellSdk.ApplicationService.Scripts.GetApplicationSearchScript.RunScript()

at Citrix.Console.PowerShellInteraction.PowerShellScript`1.Run()

at Citrix.Console.PowerShellSdk.ApplicationService.Scripts.RemoveApplicationDesktopGroupsScript.RunScript()

at Citrix.Console.PowerShellInteraction.PowerShellScript`1.Run()

at Citrix.Console.PowerShellSdk.ApplicationService.Scripts.UpdateApplicationScript.RemoveDesktopGroupAssociations()

at Citrix.Console.PowerShellSdk.ApplicationService.Scripts.UpdateApplicationScript.RemoveGroupAssociations()

at Citrix.Console.PowerShellSdk.ApplicationService.Scripts.UpdateApplicationScript.UpdateGroupAssociations()

at Citrix.Console.PowerShellSdk.ApplicationService.Scripts.UpdateApplicationScript.RunScript()

at Citrix.Console.PowerShellInteraction.PowerShellScript`1.Run()

at Citrix.Console.DesktopGroups.UI.Dialogs.EditApplicationPropertyViewModel.Commit(IProgressReporter progressReporter)

at Citrix.Console.CommonControls.Wizard.PageContainerViewModel.b__21_1(IProgressReporter progressReporter)

at Citrix.Console.CommonControls.Wizard.CommitProgressViewModel.PerformOperationInternal()

DesktopStudio_ErrorId : UnknownObject

Sdk Error Message : Object does not exist

Sdk Error ID : Citrix.XDPowerShell.Broker.UnknownObject,Citrix.Broker.Admin.SDK.GetBrokerApplicationCommand

ErrorCategory : ObjectNotFound

DesktopStudio_PowerShellHistory : GetApplicationSearchScript

9/19/2018 3:02:30 PM

Get-BrokerApplication -AdminAddress “fchctxdcp10.fm.frd.fmlh.edu:80” -MaxRecordCount 2147483647 -Name “EpicEpic 2018 REL_1”

Get-BrokerApplication : Object does not exist

+ CategoryInfo : ObjectNotFound: (:) [Get-BrokerApplication], SdkOperationException

+ FullyQualifiedErrorId : Citrix.XDPowerShell.Broker.UnknownObject,Citrix.Broker.Admin.SDK.GetBrokerApplicationCommand


Inner Exception:

Citrix.Broker.Admin.SDK.SdkOperationException Object does not exist

Inner Exception:

System.Management.Automation.ItemNotFoundException Object does not exist

Related:

ServerSocketChannel.bind () error in Oracl embedded JVM

Hello. I am researching Oracle for training purposes. I am currently trying to program in the embedded JVM.
And I found the following error:
if you use “ServerSocketChannel.bind (new InetSocketAddress (InetAddress.getLocalHost (). getHostAddress (), port)”,
then an error is caused:

**”java.net.SocketException: bind failed, errno = 10049
required address for its context is incorrect.
at sun.nio.ch.Net.bind0 (Native Method)
at sun.nio.ch.Net.bind (Net.java)
at sun.nio.ch.Net.bind (Net.java)
at sun.nio.ch.ServerSocketChannelImpl.bind (ServerSocketChannelImpl.java)
at java.nio.channels.ServerSocketChannel.bind (ServerSocketChannel.java)”**

Any attempt to bind ServerSocketChannel by name or IP address results in this error.
I have not found any description of this error on the Internet, and it is suggested that this
development error.
OS Windows7 64 bit, Windows 10. Oracle Database 18c Enterprise Edition Release 18.0.0.0.0 – Production
Version 18.3.0.0.0
Partially this error corrects: “System.setProperty (“java.net.preferIPv4Stack”, “true”)”;
In this case, ServerSocketChannel.bind () works well,
but attempt to return ip address:
“ServerSocketChannel.socket (). GetInetAddress (). GetHostAddress ());”
or
“ServerSocketChannel.getLocalAddress ();”
causes an error

“java.lang.NullPointerException
at java.net.Inet4Address.getAddress(Inet4Address.java)
at java.net.Inet4Address.getHostAddress(Inet4Address.java)
at sun.nio.ch.ServerSocketChannelImpl.accept(ServerSocketChannelImpl.java)”

therefore, this error is always called as soon as it tries to connect to the listener.
is it possible to fix it?

If this is a bug, what are the chances that Oracle will fix it?
Is it possible to send a request to the support service to eliminate this bug, if I do not have a license key?. Thank.

Related:

Device enrolment fails “Error 1700” (the gateway is unavailable)

I need a solution

Hi there.

Trying to enrol an OS X device and received a fairly unhelpful error message that hasn’t been documented anywhere that I can find.

In any case, opening the browser console makes it pretty clear something is just down.

The response body looks like this:

<html><body><h1>504 Gateway Time-out</h1>
The server didn't respond in time.
</body></html>

Summary
URL: https://sepc.securitycloud.symantec.com/api/enroll...
Status: 504
Source: Network
Address: 34.227.155.xxx:443

The request POST body looked like this:

{"product-name":"os","company-owned":"true","sep-mobile":true,"mdm-off":false}

I’m generally disappointed by the SEPC portal, but we have to use SEPC more or less because of our size (smaller than would justify an MSP), who our clients are (mostly government that requires US-based antivirus) and our devices (all Macs), so, looking for options. There’s also no obvious way to get online support except for this forum… what’s that about?

0

Related:

  • No Related Posts

ViPR Controller: “Error 2000: Unable to find entity specified” when running a custom catalog entry[1]

Article Number: 525313 Article Version: 4 Article Type: Break Fix



ViPR Controller

The user is trying to run a custom ViPR Controller Catalog entry that was created/modified and it errors with the following message:

Error 2000: Unable to find entity specified in URL with the given id urn:storageos:VirtualPool:xxx-xxx-xx-xxx:vdc1

The same type of error could occur for other URNs and not just limited to Virtual Pools.

Previously the user had used ViPR Controller’s functionality to copy an existing catalog entry, rename the copy, and edited the new catalog entry to “Lock in” some values for some of the catalog entries options.

The custom catalog entry was linked to a specific virtual Pool that had since been deleted from VIPR-C.

In this scenario, the user had deleted a virtual pool from their ViPR Controller setup.

Workaround:

Since the Virtual Pool (and Virtual Array in this example) were deleted via the GUI, and since the user had previously locked in those values in a Catalog entry, the workaround was to re-edit the catalog entry and select new values (instead of the old deleted values).

When the user edited the problem catalog entry, they noticed that the “Locked” check box was still selected but the “value” field was empty:

screenshot of catalog editing screen

The user should either select a new value or uncheck the box if they do not want to lock in a specific value.


Resolution:

ViPR Engineering is currently addressing this problem, but has not provided a fix in a released patch.

This solution will be updated with the patch when it has been released.

Related:

Dell EMC Unity: Unisphere Job page fails to load with “Error Code:0x7d13001” (Dell EMC Correctable)

Article Number: 524995 Article Version: 2 Article Type: Break Fix



Dell EMC Unity Family

When accessing Events>Jobs tab in Unisphere you are met with the following error.

The system encountered an unexpected error. Search for the error code on the support website or product forums, or contact your service provider, if available. (Error Code:0x7d13001)Reload Unisphere UI?

EMCCEMlogcemtracer.log

23 Aug 2018 11:50:16 – [COMMON_DB_SHARED_LIB] ERROR – {0:254709:387164896}[22728|28131|d77ffb40][performRequest @ ../../../components/UI/CLI/plugins/commands/common_db/src/DBOperating.cpp:55] Caught pqxx::pqxx_exception (ERROR: integer out of range).

<.>

23 Aug 2018 11:50:16 – [UemCliProvider] ERROR – {0:254709:388543223}[22728|28131|d77ffb40][processRequest @ ../../../components/providers/native/CliProvider/src/UemCliProvider.cpp:435] Request processing completed with error: The system encountered an unexpected error. Search for the error code on the support website or product forums, or contact your service provider, if available. (Error Code:0x100e000)

There is potentially a Job with an elapsed time greater than 24 days which causes the Job tab to fail to load.

Please contact Dell EMC Technical Support or your Authorized Service Representative, and quote this Knowledgebase article ID.

Fix for this issue is scheduled in a future Unity OE release. The problem is cosmetic and only affects the viewing of active jobs. The workaround is non-disruptive and will require support only commands to address.

Related:

VxRail: The server has encountered an unexpected internal error. Please try again later.” when attempting to upgrade from v 3.5 to v 4

Article Number: 500999 Article Version: 3 Article Type: Break Fix



VSPEX,VSPEX BLUE Appliance,VSPEX BLUE Appliance Hardware,VSPEX BLUE Appliance Software

Retry local upgrade from VxRail Manager failes with error ” The server has encountered an unexpected internal error. Please try again later.”

mystic@zptvxrail01:/var/log> cd mystic/

mystic@zptvxrail01:/var/log/mystic> tail -f vxrail-upgrade.log

VxRail-Upgrade: 2017-06-13 11:14:35,947.947 – ERROR Failed to Upgrade VxRail Patches, Due to ERROR: [Errno 12] Cannot allocate memory

VxRail-Upgrade: 2017-06-13 11:14:35,948.948 – DEBUG Clear PageCache, dentries, swap and inodes buffers

VxRail-Upgrade: 2017-06-13 12:29:40,066.066 – INFO Starting to Upgrade VxRail

VxRail-Upgrade: 2017-06-13 12:29:40,071.071 – DEBUG initializing vsphere parameters: Start

VxRail-Upgrade: 2017-06-13 12:29:40,089.089 – ERROR Failed to Upgrade VxRail Patches, Due to ERROR: [Errno 12] Cannot allocate memory

VxRail-Upgrade: 2017-06-13 12:29:40,091.091 – DEBUG Clear PageCache, dentries, swap and inodes buffers

VxRail-Upgrade: 2017-06-13 12:44:16,386.386 – INFO Starting to Upgrade VxRail

VxRail-Upgrade: 2017-06-13 12:44:16,386.386 – DEBUG initializing vsphere parameters: Start

VxRail-Upgrade: 2017-06-13 12:44:16,390.390 – ERROR Failed to Upgrade VxRail Patches, Due to ERROR: [Errno 12] Cannot allocate memory

VxRail-Upgrade: 2017-06-13 12:44:16,396.396 – DEBUG Clear PageCache, dentries, swap and inodes buffers

* rebooted VxRail Manager given hat the error shows Cannot allocate memory. After the reboot we could start the upgrade.

* completed upgrade from 3.5 to 4.0.100 successfully

VxRail Manager is not connected to the internet, internet upgrade is ruled out

lcm.log file is missing becuase the upgrade has not even started.

Related:

  • No Related Posts

Unisphere for VMAX 8.3.0: Unisphere 8.3.0.1 error sending mail

Article Number: 501109 Article Version: 4 Article Type: Break Fix



Unisphere for VMAX 8.3.0

Mail relay is allowed and it can resolve customer’s mail server but Customer gets mailserviceexception failed to deliver javamail message.

From the logs:

2017-05-11 08:24:15,236 ERROR [em.bp.MAIL] (default task-18) EmailNotificationCommandProcessor.processSendMailMessageCommand:Error sending mail message: javax.ejb.EJBException: com.emc.em.common.mail.MailServiceException: Failed to deliver JavaMail message

at org.jboss.as.ejb3.tx.BMTInterceptor.handleException(BMTInterceptor.java:83)

at org.jboss.as.ejb3.tx.EjbBMTInterceptor.checkStatelessDone(EjbBMTInterceptor.java:91)

at org.jboss.as.ejb3.tx.EjbBMTInterceptor.handleInvocation(EjbBMTInterceptor.java:106)

at org.jboss.as.ejb3.tx.BMTInterceptor.processInvocation(BMTInterceptor.java:58)

at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:340)

at org.jboss.invocation.InterceptorContext$Invocation.proceed(InterceptorContext.java:437)

at org.jboss.weld.ejb.AbstractEJBRequestScopeActivationInterceptor.aroundInvoke(AbstractEJBRequestScopeActivationInterceptor.java:73)

at org.jboss.as.weld.ejb.EjbRequestScopeActivationInterceptor.processInvocation(EjbRequestScopeActivationInterceptor.java:83)

at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:340)

at org.jboss.as.ee.concurrent.ConcurrentContextInterceptor.processInvocation(ConcurrentContextInterceptor.java:45)

at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:340)

at org.jboss.invocation.InitialInterceptor.processInvocation(InitialInterceptor.java:21)

at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:340)

at org.jboss.invocation.ChainedInterceptor.processInvocation(ChainedInterceptor.java:61)

at org.jboss.as.ee.component.interceptors.ComponentDispatcherInterceptor.processInvocation(ComponentDispatcherInterceptor.java:52)

at org.jboss.invocation.InterceptorContext.proceed(InterceptorContext.java:340)

.

.

.

Caused by: javax.mail.AuthenticationFailedException: 334 VXNlcm5hbWU6

at com.sun.mail.smtp.SMTPTransport$Authenticator.authenticate(SMTPTransport.java:892)

at com.sun.mail.smtp.SMTPTransport.authenticate(SMTPTransport.java:814)

at com.sun.mail.smtp.SMTPTransport.protocolConnect(SMTPTransport.java:728)

at javax.mail.Service.connect(Service.java:364)

at com.emc.em.common.mail.MailService.getTransport(MailService.java:161)

… 117 more

Customer verified against KB: 478937, and 459812 and all checked out.

Upgrading the Unisphere for VMAX to 8.4 resolved the issue. Please refer to KB 494818.

Related:

VxRail: Upload of the file to perform the upgrade fails with error message: “Failed to upload bundle: VXRAIL_COMPOSITE-4.0.132-5128179 .zip”

Article Number: 498669 Article Version: 2 Article Type: Break Fix



VxRail Appliance

The upload of the upgrade file fails with the following message:

User-added image

On the lcm.log the following error message is logged:

Apr 11 11:30:39,559 GMT 2017 ERROR [pool-11-thread-1] LCMServiceImpl.handleUploadException:959 – failed to upload upgrade bundle: VXRAIL_COMPOSITE-4.0.132-5128179 (2).zip, with exception:

com.vce.lcm.exception.LCMException: Error while unzipping the composite bundle file. Used file: /tmp/lcm/VXRAIL_COMPOSITE-4.0.132-5128179 (2).zip

at com.vce.lcm.service.composite.CompositeBundleFileUnpacker.unzipCompositeBundleFile(CompositeBundleFileUnpacker.java:165) ~[lcm_module-4.0.100.jar:?]

at com.vce.lcm.service.composite.CompositeBundleFileUnpacker.unpack(CompositeBundleFileUnpacker.java:64) ~[lcm_module-4.0.100.jar:?]

at com.vce.lcm.service.LCMServiceImpl.uploadLocalCompositeBundle(LCMServiceImpl.java:366) ~[lcm_module-4.0.100.jar:?]

at com.vce.lcm.service.LCMServiceImpl.uploadCompositeBundle(LCMServiceImpl.java:473) [lcm_module-4.0.100.jar:?]

at com.vce.lcm.service.LCMServiceImpl.uploadOfflineUpgradeBundle(LCMServiceImpl.java:107) [lcm_module-4.0.100.jar:?]

at com.emc.mystic.manager.web.service.VirtualApplianceUpgradeService.runBundleUpload(VirtualApplianceUpgradeService.java:246) [classes/:?]

at com.emc.mystic.manager.web.service.VirtualApplianceUpgradeService.access$200(VirtualApplianceUpgradeService.java:70) [classes/:?]

at com.emc.mystic.manager.web.service.VirtualApplianceUpgradeService$1.run(VirtualApplianceUpgradeService.java:194) [classes/:?]

at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_102]

at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_102]

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_102]

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_102]

at java.lang.Thread.run(Thread.java:745) [?:1.8.0_102]

Caused by: java.lang.IllegalArgumentException: Illegal character in opaque part at index 50: jar:file:/tmp/lcm/VXRAIL_COMPOSITE-4.0.132-5128179 (2).zip

Checking the line:

Caused by: java.lang.IllegalArgumentException: Illegal character in opaque part at index 50: jar:file:/tmp/lcm/VXRAIL_COMPOSITE-4.0.132-5128179 (2).zip

It says that “Illegal character in opaque part at index 50

If you count 50 characters starting at “jar:file:/tmp/lcm/VXRAIL_COMPOSITE-4.0.132-5128179(2).zip“, the 50th character is the space..

Rename the file to remove the space out of it and try to upload it again

Related:

  • No Related Posts

how to configure application control using the command line ?

I need a solution

hello, is it possible to setup application control using the command line ?  we’re using the unmanaged SEP client, version 14.  i know i can allow an application access to the network by using the GUI ( open the SEP client, click Options next to the Network and Host Exploit Mitigation, click Application Settings, then Configure).  is there a way to do this using a windows command line please ?  

we’re using IBM’s Bigfix product to remotely install a new application on our windows machines.  but we don’t have a way to configure SEP to allow the new application’s traffic without logging into each machine and using the GUI.

thanks much….steve.

0

1537820568

Related: