Datacap webservice does not process the vscan task

We are running Datacap 9.1.1 on Windows 2012.
We have a Datacap application based on the standard template that we need to call via web service.
I tried to simulate the process using Postman (similar to Fiddler) to generate the REST calls. Our input files are in a folder as they would be if the process was run via the Datacap Studio. The process seems to perform the vscanmulti task but the result is just a vscanmulti.xml page file in the batch folder. The next task PageId obviously gets stuck as pending as no file was scanned. I tried using GrabBatch and Release but they just generate pagefiles in the Batch folder with the task names but no processing is performed. No task logs are produced either.
How do I get the app to process vscan then followed by the remaining tasks? I understand that I need to use the GetPageFile and SetPageFile but that is only after the scan is performed successfully.

The following are the steps:

1. /Session/Logon – successful
2. /Queue/CreateBatch – apparently successful. Request includes the pagefile definition.
3. /Queue/ReleaseBatch/AppDev/135/finished – successful
4. /Queue/GrabBatch/AppDev/135 – successful
5. /Queue/ReleaseBatch/AppDev/135/finished – successful
6. etc.

I have reviewed both the Knowledge Center and the IBM Datacap V9.0 Installing and Using Datacap Web Services.pdf as well as the Datacap-Web-Services-Projects sample from DeveloperWorks.
Thanks in advance.


Leave a Reply