How to configure Secure Gateway to use Proxy?

Hello,

I’ve run into an issue with Secure Gateway configuration at a customer. The SG client fails to connect to the Secure Gateway with the below error. I am able to access the configuration URL in question (see DEBUG line) via a browser which uses a proxy, so I suspect the connection fails due to direct access to HTTP/HTTPS ports being blocked by the firewall, which is very common with big customers.

Is there a way to configure SG Client to use a Proxy?

Thank you!

[2017-10-17 17:03:14.560] [INFO] (Client ID 2160) Setting log level to DEBUG
[2017-10-17 17:03:14.568] [DEBUG] (Client ID 2160) The Secure Gateway client will fetch its configuration from https://sgmanager.ng.bluemix.net/sgconfig/XXXXXXXXXX_prod_ng
[2017-10-17 17:03:14.787] [ERROR] (Client ID 2160) The response is code: ECONNRESET, message: read
cli> [2017-10-17 17:03:14.791] [INFO] (Client ID 2160) Process exiting without errors due to user or server request
 

Related:

Leave a Reply