One of the slaves in RHEL bond doesn’t work

I have a red-hat enterprise Linux 6.3 vm (VMware vsphere).

I created a bond from two interfaces and it works but only when eth0 is active. When I use ifdown eth0 or echo -eth0 > /sys/class/net/bond0/bonding/slaves I lose network connectivity to the bond.

I could see on cat /proc/net/bond0 that the two interfaces are in the bond and when eth1 is active it does not work.

If I add eth0 back again it still doesn’t work because eth1 is the active one. Only if I remove and readd eth1 to the bond it works (making eth0 the active)

The bond is of course in a fault tolerance mode.

The strange part is if I remove eth1 from the bond and define it as a simple interface it works just fine!

I tried reboot (many times), and could not find any help on the web. I even tried removing the interface (from VMware side) and adding a new one but that didn’t help. anyone got an idea?

Some of the commands might not be accurate because I write this from my phone using my memory but I think you know what I meant, just don’t suggest that a typo or syntax error was the problem.

Thanks in advance

Related:


Leave a Reply