SCCM 2012 and WSUS…missing Schema folder

A few months ago I installed SCCM 2012 R2 on a brand new 2012 R2 box. Everything went smoothly…or so it seems. I attempted to install WSUS to make it work with SCCM. A few hours of struggling later, I thought I had a working install.

Wrong again.

Turns out, the C:\Program Files\Update Services\Schema folder is nowhere to be found. Searching has found running the post install again may work, but it didn’t appear. Updates haven’t been working since around the install date.

What would be the next step? I can’t reinstall SCCM as a whole because I have Endpoint Protection deployed to all of our PCs.

Edit: Here is the line from WCM.log that pointed out this error:

PublishApplication(8427071A-DA80-48C3-97DE-C9C528F73A2D) failed with
error System.IO.DirectoryNotFoundException: Could not find a part of
the path ‘C:\Program Files\Update
Services\Schema\baseapplicabilityrules.xsd’.~~ at -big long string of crap-

$$<04-01-2014
13:59:57.336+240> Done using CORP\Administrator
credentials~ $$<04-01-2014
13:59:57.336+240> ERROR: Failed to publish sms
client to WSUS, error = 0x80070003
$$<04-01-2014
13:59:57.336+240>

Edit2: Had the idea of firing up my old WSUS server (running 2008R2) and copying the missing folder over, but that didn’t work either:

PublishApplication(8427071A-DA80-48C3-97DE-C9C528F73A2D) failed with
error System.Xml.Schema.XmlSchemaValidationException: The element
http://schemas.microsoft.com/wsus/2005/04/CorporatePublishing/UpdateServicesPackage.xsd:File
cannot contain child element
http://schemas.microsoft.com/wsus/2005/04/CorporatePublishing/SoftwareDistributionPackage.xsd:AdditionalDigest
because the parent element’s content model is empty.~~~

Related:


Leave a Reply