Segmentation fault running appscansrccli


we’re trying to automate the AppScan Source process within our Continuous Delivery build pipeline. To do so, we first started by creating a Docker container for that purpose (see the Dockerfile attached).

Based on the officially supported RHEL version 6, I used its cousin image CentOS 6.7. We face a Segmentation Fault whenever we try to login from the AppScan console. Here are the full steps to reproduce:

• Build Docker image using command “docker build .” (the image includes the installation of required 32bits packages: libX11.i686, libXtst.i686, gtk2.i686, glibc.i686, libgcc.i686 and webkitgtk.i686)
• Launch a container with the command “docker run -it —privileged ”
• Launch the AppScan command line tool with “/opt/ibm/appscansource/bin/appscansrccli”
• Issue a login command: “login -acceptssl”

The result:


root@1ceb7c7e52db bin]# ./appscansrccli

Welcome to IBM Security AppScan Source!

login -acceptssl

./appscansrccli: line 26: 34 Segmentation fault “${BINDIRECTORY}/cliloader” “$@” 2> /dev/null


I have tried without the leading https://, same result

The following has also been tried on a vagrant image also using CentOS with the same results.

Other notable attempts:

Manually installed in the running container some debugging requirements from the Dockerfile:
yum install -y valgrind
yum install -y valgrind.i686
yum install -y strace
I used “strace -yxvf -p 2618 -o /root/strace.log” within the container to see if there was an obvious reason for the failure, but it seems to fail directly in the cliloader executable
Also tried running the console while wrapped in valgrind with “valgrind –log-file=/root/valgrind.log –leak-check=full /opt/ibm/appscansource/bin/cliloader”, which sadly gave me a “login successful” message (did not reproduce the Segmentation Fault). Thought I must say that valgrind is reporting a lot of errors on that successful command…
We did a similar setup on our Macs (without Docker), and the login works

Any help would be appreciated.


Leave a Reply