7022320: Various commands failing after change of the default region name

This document (7022320) is provided subject to the disclaimer at the end of this document.

Environment

SUSE OpenStack Cloud 6

Situation

After changing the default region name in Keystone suddenly a various commands are failing.

In log files the following can be seen:

admin endpoint for identity service in Cloud region not found

Resolution

Set the correct region name for a specific endpoint with the command:

openstack endpoint set –region <newregionname> <id-of-the-endpoint>

Other option is to return to the default RegionOne name.

Cause

New region name is set correctly during the first time deployment. However changing it on a deployed cloud doesn’t work for Keystone and has to be done manually. Issue is known and updated code will be released via maintenance channels.

Disclaimer

This Support Knowledgebase provides a valuable tool for NetIQ/Novell/SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented “AS IS” WITHOUT WARRANTY OF ANY KIND.

Related:

Leave a Reply