XenApp 7.x: Error: the data base is already been configured

Error: the data base is already been configured.

Error Id: XDDS:36FD07F4

Exception:

Citrix.Console.Models.Exceptions.ScriptException The database has already been configured.

at Citrix.Console.PowerShellInteraction.CmdletExecutionMethods.CreateException[T](ICommonLog logger, ExecutionResults`1 results, ICmdletExecutionHost host)

at Citrix.Console.PowerShellInteraction.CmdletExecutionMethods.Execute[T](ISdkCmdlet`1 sdkCmd, ICmdletExecutionHost host, Boolean allowFailover)

at Citrix.Console.PowerShellInteraction.SdkServiceBase.SetDatabaseConnection(ICmdletExecutionHost cmdletExecutionHost, String instanceAddress, DataStore dataStore, String databaseConnection, Boolean force)

at Citrix.Console.PowerShellSdk.UpgradeService.UpgradeTasks.ServiceConfigurationTask.AttachServiceDatastoresToDatabaseServer(ServiceEndpointAnalysis servicesWithUnregisteredServiceInstance, ICmdletExecutionHost host, String databaseConnection)

at Citrix.Console.PowerShellSdk.UpgradeService.UpgradeTasks.ServiceConfigurationTask.<>c__DisplayClass10_0.<RunUpgradeTask>b__5(ICmdletExecutionHost host)

at Citrix.Console.PowerShellInteraction.SimplePowerShellScript.<>c__DisplayClass4_0.<Run>b__0(ICmdletExecutionHost host)

at Citrix.Console.PowerShellInteraction.PowerShellScript`1.Run()

at Citrix.Console.PowerShellSdk.UpgradeService.UpgradeTasks.ServiceConfigurationTask.RunUpgradeTask(IProgressReporter progressReporter, ITaskLogger taskLogger)

at Citrix.Console.PowerShellSdk.UpgradeService.UpgradeTasks.UpgradeTaskBase.RunUpgrade(IProgressReporter progressReporter, ITaskLogger taskLogger)

at Citrix.Console.PowerShellSdk.UpgradeService.UpgradeTasks.UpgradeTaskBase.RunUpgrade(IProgressReporter progressReporter, ITaskLogger taskLogger)

at Citrix.Console.PowerShellSdk.UpgradeService.UpgradeTasks.Upgrade.RunUpgradeTask(IProgressReporter progressReporter, ITaskLogger taskLogger)

at Citrix.Console.PowerShellSdk.UpgradeService.UpgradeTasks.UpgradeTaskBase.RunUpgrade(IProgressReporter progressReporter, ITaskLogger taskLogger)

at Citrix.Console.DeliveryCenter.UI.Mmc.UpgradeResultPaneViewModel.UpgradeTask(IProgressReporter progressReporter, UserCredentials databaseCredentials)

at Citrix.Console.Common.OperationTimer.TimeBlock(Action operation)

at Citrix.Console.CommonControls.ProgressDisplay.GenericProgressOperationWithFeedBack.PerformOperationInternal()

at Citrix.Console.CommonControls.ProgressDisplay.ProgressWindowOperation.PerformOperation()

at Citrix.Console.CommonControls.ProgressDisplay.ProgressWindowViewModel.PerformAction(Action operationComplete)

DesktopStudio_ErrorId : DatabaseConnectionDetailsAlreadyConfigured

Sdk Error Message : Cannot transition directly from using one data store to another; clear the existing data-store connection first.

Sdk Error ID : Citrix.XDPowerShell.Status.DatabaseConnectionDetailsAlreadyConfigured,Citrix.EnvTest.Sdk.DataStore.Commands.SetEnvTestDBConnectionCommand

ErrorCategory : NotSpecified

DesktopStudio_PowerShellHistory : SimplePowerShellScript

Related:

  • No Related Posts

RecoverPoint for Virtual Machines: Plugin not displaying clusters, RP CLI shows that the connection to VC failed

Article Number: 502403 Article Version: 3 Article Type: Break Fix



RecoverPoint for Virtual Machines,RecoverPoint for Virtual Machines 5.0 SP1

Issue:

Plugin not displaying clusters, RP CLI shows that the connection to VC failed

VIConnector is crashing with Null pointer exception while building the VIView resulting in on-going DRU and plugin missing from the VC.


Symptoms found in the logs:

In VIConnector logs:

2017-06-30 07:34:43,643 [pool-6-thread-1] (VCUpdater.java:474) DEBUG – Unlocking full sync.

2017-06-30 07:34:43,643 [pool-6-thread-1] (VCUpdater.java:408) ERROR – Exception caught

java.lang.NullPointerException

at com.emc.recoverpoint.connectors.vi.infra.EntitiesUtils.getEsxClusterForVm(EntitiesUtils.java:134) ~[vi_connector_commons.jar:?]

at com.emc.recoverpoint.connectors.vi.builder.VMStateBuilder.getEsxClusterUuid(VMStateBuilder.java:82) ~[vi_connector_commons.jar:?]

at com.emc.recoverpoint.connectors.vi.builder.VMStateBuilder.create(VMStateBuilder.java:45) ~[vi_connector_commons.jar:?]


Affected versions:

All RP4VMs versions

Root cause:

Customer replicated a template VM, which is not supported

Workaround:

Make sure no templates are being replicated


Resolution Fixed at:

N/A

Related:

  • No Related Posts